o 0¦iÅ;ã@sˆdZdZddlZdZdZGdd„deƒZGdd „d eƒZd d „Zd=d d„Z dd„Z dd„Z dd„Z dd„Z dd„Zdd„Zdd„Zdd„Zdd „Zd!d"„ZGd#d$„d$ƒZdaejGd%d&„d&eƒƒZejGd'd(„d(eƒƒZGd)d*„d*ƒZGd+d,„d,eeƒZGd-d.„d.eƒZGd/d0„d0eeƒZGd1d2„d2ƒZee_Gd3d4„d4ƒZGd5d6„d6eeƒZ Gd7d8„d8e ƒZ!Gd9d:„d:eeƒZ"Gd;d<„d<ƒZ#e#e _dS)>z•A fast, lightweight IPv4/IPv6 manipulation library in Python. This library is used to create/poke/manipulate IPv4 and IPv6 addresses and networks. z1.0éNé é€c@óeZdZdZdS)ÚAddressValueErrorz%A Value Error related to the address.N©Ú__name__Ú __module__Ú __qualname__Ú__doc__©r r ú0/opt/alt/python310/lib64/python3.10/ipaddress.pyrórc@r)ÚNetmaskValueErrorz%A Value Error related to the netmask.Nrr r r r rr rc CóRzt|ƒWSttfyYnwzt|ƒWSttfy!Ynwt|›d�ƒ‚)a®Take an IP string/int and return an object of the correct type. Args: address: A string or integer, the IP address. Either IPv4 or IPv6 addresses may be supplied; integers less than 2**32 will be considered to be IPv4 by default. Returns: An IPv4Address or IPv6Address object. Raises: ValueError: if the *address* passed isn't either a v4 or a v6 address z. does not appear to be an IPv4 or IPv6 address)Ú IPv4AddressrrÚ IPv6AddressÚ ValueError©Úaddressr r r Ú ip_addresss ÿ ÿrTc CsVzt||ƒWSttfyYnwzt||ƒWSttfy#Ynwt|›d�ƒ‚)aÐTake an IP string/int and return an object of the correct type. Args: address: A string or integer, the IP network. Either IPv4 or IPv6 networks may be supplied; integers less than 2**32 will be considered to be IPv4 by default. Returns: An IPv4Network or IPv6Network object. Raises: ValueError: if the string passed isn't either a v4 or a v6 address. Or if the network has host bits set. z. does not appear to be an IPv4 or IPv6 network)Ú IPv4NetworkrrÚ IPv6Networkr)rÚstrictr r r Ú ip_network9s ÿ ÿrc Cr)agTake an IP string/int and return an object of the correct type. Args: address: A string or integer, the IP address. Either IPv4 or IPv6 addresses may be supplied; integers less than 2**32 will be considered to be IPv4 by default. Returns: An IPv4Interface or IPv6Interface object. Raises: ValueError: if the string passed isn't either a v4 or a v6 address. Notes: The IPv?Interface classes describe an Address on a particular Network, so they're basically a combination of both the Address and Network classes. z0 does not appear to be an IPv4 or IPv6 interface)Ú IPv4InterfacerrÚ IPv6Interfacerrr r r Ú ip_interfaceVs ÿ ÿrcCó&z| dd¡WStytdƒ‚w)a`Represent an address as 4 packed bytes in network (big-endian) order. Args: address: An integer representation of an IPv4 IP address. Returns: The integer address packed as 4 bytes in network (big-endian) order. Raises: ValueError: If the integer is negative or too large to be an IPv4 IP address. éÚbigz&Address negative or too large for IPv4©Úto_bytesÚ OverflowErrorrrr r r Úv4_int_to_packedxs  ÿr#cCr)zõRepresent an address as 16 packed bytes in network (big-endian) order. Args: address: An integer representation of an IPv6 IP address. Returns: The integer address packed as 16 bytes in network (big-endian) order. érz&Address negative or too large for IPv6r rr r r Úv6_int_to_packedŒs   ÿr%cCs,t|ƒ d¡}t|ƒdkrtd|›�ƒ‚|S)zAHelper to split the netmask and raise AddressValueError if neededú/ézOnly one '/' permitted in )ÚstrÚsplitÚlenr)rÚaddrr r r Ú_split_optional_netmaskœs r,ccsP�t|ƒ}t|ƒ}}|D]}|j|jdkr||fV|}|}q ||fVdS)zÏFind a sequence of sorted deduplicated IPv#Address. Args: addresses: a list of IPv#Address objects. Yields: A tuple containing the first and last IP addresses in the sequence. éN)ÚiterÚnextÚ_ip)Ú addressesÚitÚfirstÚlastÚipr r r Ú_find_address_range¤s€  r6cCs$|dkr|St|||d@ ¡ƒS)zåCount the number of zero bits on the right hand side. Args: number: an integer. bits: maximum number of bits to count. Returns: The number of zero bits on the right hand side of the number. rr-)ÚminÚ bit_length)ZnumberÚbitsr r r Ú_count_righthand_zero_bits¸s r:ccsð�t|tƒr t|tƒstdƒ‚|j|jkrtd||fƒ‚||kr%tdƒ‚|jdkr-t}n |jdkr5t}ntdƒ‚|j}|j}|j}||krvt t ||ƒ||d  ¡dƒ}||||fƒ}|V|d|>7}|d|j krpdS||ksFdSdS) a¤Summarize a network range given the first and last IP addresses. Example: >>> list(summarize_address_range(IPv4Address('192.0.2.0'), ... IPv4Address('192.0.2.130'))) ... #doctest: +NORMALIZE_WHITESPACE [IPv4Network('192.0.2.0/25'), IPv4Network('192.0.2.128/31'), IPv4Network('192.0.2.130/32')] Args: first: the first IPv4Address or IPv6Address in the range. last: the last IPv4Address or IPv6Address in the range. Returns: An iterator of the summarized IPv(4|6) network objects. Raise: TypeError: If the first and last objects are not IP addresses. If the first and last objects are not the same version. ValueError: If the last object is not greater than the first. If the version of the first address is not 4 or 6. z1first and last must be IP addresses, not networksú%%s and %s are not of the same versionz*last IP address must be greater than firstrézunknown IP versionr-N) Ú isinstanceÚ _BaseAddressÚ TypeErrorÚversionrrrÚ_max_prefixlenr0r7r:r8Ú _ALL_ONES)r3r4r5Zip_bitsZ first_intZlast_intZnbitsÚnetr r r Úsummarize_address_rangeÈs:€ ÿ ÿ   ÿ ùrDccs”�t|ƒ}i}|r-| ¡}| ¡}| |¡}|dur|||<n ||kr+||=| |¡|s d}t| ¡ƒD]}|durB|j|jkrBq5|V|}q5dS)auLoops through the addresses, collapsing concurrent netblocks. Example: ip1 = IPv4Network('192.0.2.0/26') ip2 = IPv4Network('192.0.2.64/26') ip3 = IPv4Network('192.0.2.128/26') ip4 = IPv4Network('192.0.2.192/26') _collapse_addresses_internal([ip1, ip2, ip3, ip4]) -> [IPv4Network('192.0.2.0/24')] This shouldn't be called directly; it is called via collapse_addresses([]). Args: addresses: A list of IPv4Network's or IPv6Network's Returns: A list of IPv4Network's or IPv6Network's depending on what we were passed. N)ÚlistÚpopÚsupernetÚgetÚappendÚsortedÚvaluesÚbroadcast_address)r1Zto_mergeÚsubnetsrCrGZexistingr4r r r Ú_collapse_addresses_internalÿs*€   ÷  ùrNc Cs(g}g}g}|D]l}t|tƒr)|r#|dj|jkr#td||dfƒ‚| |¡q|j|jkr[|rC|dj|jkrCtd||dfƒ‚z| |j¡WqtyZ| |j ¡Yqw|ro|dj|jkrotd||dfƒ‚| |¡qt t |ƒƒ}|rŽt |ƒD] \}}|  t||ƒ¡q�t||ƒS)aËCollapse a list of IP objects. Example: collapse_addresses([IPv4Network('192.0.2.0/25'), IPv4Network('192.0.2.128/25')]) -> [IPv4Network('192.0.2.0/24')] Args: addresses: An iterable of IPv4Network or IPv6Network objects. Returns: An iterator of the collapsed IPv(4|6)Network objects. Raises: TypeError: If passed a list of mixed version objects. éÿÿÿÿr;)r=r>Ú_versionr?rIÚ _prefixlenrAr5ÚAttributeErrorÚnetwork_addressrJÚsetr6ÚextendrDrN)r1ZaddrsZipsZnetsr5r3r4r r r Úcollapse_addresses0s< ÿ  ÿ ÿÿ   rVcCs(t|tƒr | ¡St|tƒr| ¡StS)a2Return a key suitable for sorting between networks and addresses. Address and Network objects are not sortable by default; they're fundamentally different so the expression IPv4Address('192.0.2.0') <= IPv4Network('192.0.2.0/24') doesn't make any sense. There are some times however, where you may wish to have ipaddress sort these for you anyway. If you need to do this, you can use this function as the key= argument to sorted(). Args: obj: either a Network or Address object. Returns: appropriate key. )r=Ú _BaseNetworkÚ_get_networks_keyr>Ú_get_address_keyÚNotImplemented)Úobjr r r Úget_mixed_type_keyfs  r\c@s¤eZdZdZdZedd„ƒZedd„ƒZedd„ƒZed d „ƒZ d d „Z d d„Z e dd„ƒZ e dd„ƒZe dd„ƒZe dd„ƒZe dd„ƒZe dd„ƒZdd„ZdS)Ú_IPAddressBasezThe mother class.r cCó| ¡S)z:Return the longhand version of the IP address as a string.)Ú_explode_shorthand_ip_string©Úselfr r r Úexploded…óz_IPAddressBase.explodedcCót|ƒS)z;Return the shorthand version of the IP address as a string.©r(r`r r r Ú compressedŠrcz_IPAddressBase.compressedcCr^)aIThe name of the reverse DNS pointer for the IP address, e.g.: >>> ipaddress.ip_address("127.0.0.1").reverse_pointer '1.0.0.127.in-addr.arpa' >>> ipaddress.ip_address("2001:db8::1").reverse_pointer '1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.8.b.d.0.1.0.0.2.ip6.arpa' )Ú_reverse_pointerr`r r r Úreverse_pointer�ó z_IPAddressBase.reverse_pointercCódt|ƒf}t|ƒ‚)Nz%200s has no version specified©ÚtypeÚNotImplementedError©raÚmsgr r r r@šsz_IPAddressBase.versioncCsF|dkrd}t|||jfƒ‚||jkr!d}t|||j|jfƒ‚dS)Nrz-%d (< 0) is not permitted as an IPv%d addressz2%d (>= 2**%d) is not permitted as an IPv%d address)rrPrBrA)rarror r r Ú_check_int_addressŸs  ÿþz!_IPAddressBase._check_int_addresscCs.t|ƒ}||krd}t|||||jfƒ‚dS)Nz6%r (len %d != %d) is not permitted as an IPv%d address)r*rrP)rarZ expected_lenZ address_lenror r r Ú_check_packed_address¨sÿþz$_IPAddressBase._check_packed_addresscCs|j|j|?AS)z¦Turn the prefix length into a bitwise netmask Args: prefixlen: An integer, the prefix length. Returns: An integer. )rB)ÚclsÚ prefixlenr r r Ú_ip_int_from_prefix¯s z"_IPAddressBase._ip_int_from_prefixc Cs\t||jƒ}|j|}||?}d|>d}||kr,|jd}| |d¡}d}t||ƒ‚|S)aReturn prefix length from the bitwise netmask. Args: ip_int: An integer, the netmask in expanded bitwise format Returns: An integer, the prefix length. Raises: ValueError: If the input intermingles zeroes & ones r-érz&Netmask pattern %r mixes zeroes & ones)r:rAr!r) rrÚip_intZtrailing_zeroesrsZ leading_onesZall_onesZbyteslenZdetailsror r r Ú_prefix_from_ip_int¼s ÿ     z"_IPAddressBase._prefix_from_ip_intcCsd|}t|ƒd‚)Nz%r is not a valid netmask)r)rrZ netmask_strror r r Ú_report_invalid_netmaskÕs z&_IPAddressBase._report_invalid_netmaskcCsj| ¡r| ¡s | |¡zt|ƒ}Wnty!| |¡Ynwd|kr-|jks3n| |¡|S)a Return prefix length from a numeric string Args: prefixlen_str: The string to be converted Returns: An integer, the prefix length. Raises: NetmaskValueError: If the input is not a valid netmask r)ÚisasciiÚisdigitrxÚintrrA)rrZ prefixlen_strrsr r r Ú_prefix_from_prefix_stringÚs   ÿ z)_IPAddressBase._prefix_from_prefix_stringcCs‚z| |¡}Wnty| |¡Ynwz| |¡WSty%Ynw||jN}z| |¡WSty@| |¡YdSw)aTurn a netmask/hostmask string into a prefix length Args: ip_str: The netmask/hostmask to be converted Returns: An integer, the prefix length. Raises: NetmaskValueError: If the input is not a valid netmask/hostmask N)Ú_ip_int_from_stringrrxrwrrB)rrÚip_strrvr r r Ú_prefix_from_ip_stringós  ÿ  ÿ   ÿz%_IPAddressBase._prefix_from_ip_stringcCsHt|ttfƒr ||jfSt|tƒst|ƒ}t|ƒdkr|S|d|jfS)zµHelper function to parse address of Network/Interface. Arg: address: Argument of Network/Interface. Returns: (addr, prefix) tuple. r-r)r=Úbytesr{rAÚtupler,r*)rrrr r r Ú_split_addr_prefixs   z!_IPAddressBase._split_addr_prefixcCs|jt|ƒffS©N)Ú __class__r(r`r r r Ú __reduce__-óz_IPAddressBase.__reduce__N)rrr r Ú __slots__Úpropertyrbrfrhr@rprqÚ classmethodrtrwrxr|rr‚r…r r r r r]s4          !  r]csteZdZdZdZdd„Zdd„Zdd„Zd d „Zd d „Z d d„Z dd„Z dd„Z dd„Z dd„Z‡fdd„Z‡ZS)r>z€A generic IP object. This IP class contains the version independent methods which are used by single IP addresses. r cCó|jSrƒ)r0r`r r r Ú__int__>sz_BaseAddress.__int__cCs2z |j|jko |j|jkWStytYSwrƒ)r0rPrRrZ©raÚotherr r r Ú__eq__As  ÿ ÿz_BaseAddress.__eq__cCsFt|tƒstS|j|jkrtd||fƒ‚|j|jkr!|j|jkSdS©Nr;F)r=r>rZrPr?r0rŒr r r Ú__lt__Hs  ÿ  z_BaseAddress.__lt__cCs t|tƒstS| t|ƒ|¡Srƒ©r=r{rZr„rŒr r r Ú__add__Tó z_BaseAddress.__add__cCs t|tƒstS| t|ƒ|¡Srƒr‘rŒr r r Ú__sub__Yr“z_BaseAddress.__sub__cCód|jjt|ƒfS©Nz%s(%r)©r„rr(r`r r r Ú__repr__^óz_BaseAddress.__repr__cCst| |j¡ƒSrƒ)r(Ú_string_from_ip_intr0r`r r r Ú__str__ar†z_BaseAddress.__str__cCsttt|jƒƒƒSrƒ)ÚhashÚhexr{r0r`r r r Ú__hash__dsz_BaseAddress.__hash__cCs |j|fSrƒ©rPr`r r r rYgs z_BaseAddress._get_address_keycCs|j|jffSrƒ)r„r0r`r r r r…jsz_BaseAddress.__reduce__csÖ|r|ddkrtt|ƒ|ƒStdurddl}| d¡at |¡}|s)tƒ |¡S| ¡\}}}|dkr>|j dkr3s r>c@s`eZdZdZdd„Zdd„Zdd„Zdd „Zd d „Zd d „Z dd„Z dd„Z dd„Z dd„Z ejdd„ƒZejdd„ƒZedd„ƒZedd„ƒZedd„ƒZed d!„ƒZed"d#„ƒZed$d%„ƒZd&d'„Zd(d)„Zd*d+„ZdFd.d/„ZdFd0d1„Zed2d3„ƒZed4d5„ƒZ d6d7„Z!d8d9„Z"ed:d;„ƒZ#edd?„ƒZ%ed@dA„ƒZ&edBdC„ƒZ'edDdE„ƒZ(d-S)GrWz}A generic IP network object. This IP class contains the version independent methods which are used by networks. cCr•r–r—r`r r r r˜§r™z_BaseNetwork.__repr__cCód|j|jfS©Nú%s/%d)rSrsr`r r r r›ªr†z_BaseNetwork.__str__ccs:�t|jƒ}t|jƒ}t|d|ƒD]}| |¡VqdS)zŸGenerate Iterator over usable hosts in a network. This is like __iter__ except it doesn't return the network or broadcast addresses. r-N©r{rSrLÚrangeÚ_address_class©raÚnetworkÚ broadcastr£r r r Úhosts­s €  ÿz_BaseNetwork.hostsccs:�t|jƒ}t|jƒ}t||dƒD]}| |¡VqdS)Nr-r³r¶r r r Ú__iter__¹s €  ÿz_BaseNetwork.__iter__cCsht|jƒ}t|jƒ}|dkr|||krtdƒ‚| ||¡S|d7}|||kr-tdƒ‚| ||¡S)Nrzaddress out of ranger-)r{rSrLÚ IndexErrorrµ)rar¡r·r¸r r r Ú __getitem__¿s    z_BaseNetwork.__getitem__cCs^t|tƒstS|j|jkrtd||fƒ‚|j|jkr!|j|jkS|j|jkr-|j|jkSdSr�)r=rWrZrPr?rSÚnetmaskrŒr r r r�Ìs  ÿ    z_BaseNetwork.__lt__cCsFz|j|jko|j|jkot|jƒt|jƒkWSty"tYSwrƒ)rPrSr{r½rRrZrŒr r r rŽØs  ÿþ ÿz_BaseNetwork.__eq__cCstt|jƒt|jƒfƒSrƒ)rœr{rSr½r`r r r ržàsz_BaseNetwork.__hash__cCs4|j|jkrdSt|tƒrdS|j|jj@|jjkS©NF)rPr=rWr0r½rSrŒr r r Ú __contains__ãs  z_BaseNetwork.__contains__cCs(|j|vp|j|vp|j|vp|j|vS)z*Tell if self is partly contained in other.)rSrLrŒr r r Úoverlapsïs   ýz_BaseNetwork.overlapscCs| t|jƒt|jƒB¡Srƒ)rµr{rSÚhostmaskr`r r r rLös ÿz_BaseNetwork.broadcast_addresscCs| t|jƒ|jA¡Srƒ)rµr{r½rBr`r r r rÁûsz_BaseNetwork.hostmaskcCr°r±)rSrQr`r r r Úwith_prefixlenÿóz_BaseNetwork.with_prefixlencCr°©Nú%s/%s)rSr½r`r r r Ú with_netmaskrÃz_BaseNetwork.with_netmaskcCr°rÄ)rSrÁr`r r r Ú with_hostmaskrÃz_BaseNetwork.with_hostmaskcCst|jƒt|jƒdS)z&Number of hosts in the current subnet.r-)r{rLrSr`r r r Ú num_addresses sz_BaseNetwork.num_addressescCrj)Nz%%200s has no associated address classrkrnr r r rµsz_BaseNetwork._address_classcCrŠrƒ)rQr`r r r rsóz_BaseNetwork.prefixlenccs �|j|jkstd||fƒ‚t|tƒstd|ƒ‚| |¡s'td||fƒ‚||kr-dS| d|j|jf¡}|  ¡\}}||kru||kru| |¡rU|V|  ¡\}}n| |¡rd|V|  ¡\}}n t d|||fƒ‚||kru||ksF||kr~|VdS||kr‡|VdSt d|||fƒ‚)aºRemove an address from a larger block. For example: addr1 = ip_network('192.0.2.0/28') addr2 = ip_network('192.0.2.1/32') list(addr1.address_exclude(addr2)) = [IPv4Network('192.0.2.0/32'), IPv4Network('192.0.2.2/31'), IPv4Network('192.0.2.4/30'), IPv4Network('192.0.2.8/29')] or IPv6: addr1 = ip_network('2001:db8::1/32') addr2 = ip_network('2001:db8::1/128') list(addr1.address_exclude(addr2)) = [ip_network('2001:db8::1/128'), ip_network('2001:db8::2/127'), ip_network('2001:db8::4/126'), ip_network('2001:db8::8/125'), ... ip_network('2001:db8:8000::/33')] Args: other: An IPv4Network or IPv6Network object of the same type. Returns: An iterator of the IPv(4|6)Network objects which is self minus other. Raises: TypeError: If self and other are of differing address versions, or if other is not a network object. ValueError: If other is not completely contained by self. r;z%s is not a network objectz%s not contained in %sNrÅz3Error performing exclusion: s1: %s s2: %s other: %s) rPr?r=rWÚ subnet_ofrr„rSrsrMÚAssertionError)rar�Ús1Ús2r r r Úaddress_excludesB€ $ÿ    ÿ   þ÷  þz_BaseNetwork.address_excludecCs`|j|jkrtd||fƒ‚|j|jkrdS|j|jkrdS|j|jkr&dS|j|jkr.dSdS)a¥Compare two IP objects. This is only concerned about the comparison of the integer representation of the network addresses. This means that the host bits aren't considered at all in this method. If you want to compare host bits, you can easily enough do a 'HostA._ip < HostB._ip' Args: other: An IP object. Returns: If the IP versions of self and other are the same, returns: -1 if self < other: eg: IPv4Network('192.0.2.0/25') < IPv4Network('192.0.2.128/25') IPv6Network('2001:db8::1000/124') < IPv6Network('2001:db8::2000/124') 0 if self == other eg: IPv4Network('192.0.2.0/24') == IPv4Network('192.0.2.0/24') IPv6Network('2001:db8::1000/124') == IPv6Network('2001:db8::1000/124') 1 if self > other eg: IPv4Network('192.0.2.128/25') > IPv4Network('192.0.2.0/25') IPv6Network('2001:db8::2000/124') > IPv6Network('2001:db8::1000/124') Raises: TypeError if the IP versions are different. z"%s and %s are not of the same typerOr-r)rPr?rSr½rŒr r r Úcompare_networksgs !ÿ    z_BaseNetwork.compare_networkscCs|j|j|jfS)zËNetwork-only key function. Returns an object that identifies this address' network and netmask. This function is a suitable "key" argument for sorted() and list.sort(). )rPrSr½r`r r r rX—sz_BaseNetwork._get_networks_keyr-Nc csÔ�|j|jkr |VdS|dur&||jkrtdƒ‚|dkr!tdƒ‚||j}|dkr.tdƒ‚|j|}||jkr@td||fƒ‚t|jƒ}t|jƒd}t|jƒd|?}t|||ƒD] }| ||f¡}|Vq[dS)aÓThe subnets which join to make the current subnet. In the case that self contains only one IP (self._prefixlen == 32 for IPv4 or self._prefixlen == 128 for IPv6), yield an iterator with just ourself. Args: prefixlen_diff: An integer, the amount the prefix length should be increased by. This should not be set if new_prefix is also set. new_prefix: The desired new prefix length. This must be a larger number (smaller prefix) than the existing prefix. This should not be set if prefixlen_diff is also set. Returns: An iterator of IPv(4|6) objects. Raises: ValueError: The prefixlen_diff is too small or too large. OR prefixlen_diff and new_prefix are both set or new_prefix is a smaller number than the current prefix (smaller number means a larger network) Nznew prefix must be longerr-ú(cannot set prefixlen_diff and new_prefixrzprefix length diff must be > 0z0prefix length diff %d is invalid for netblock %s) rQrArr{rSrLrÁr´r„) raÚprefixlen_diffÚ new_prefixÚ new_prefixlenÚstartÚendÚstepZnew_addrZcurrentr r r rM¡s4€     ÿÿ þz_BaseNetwork.subnetscCsˆ|jdkr|S|dur!||jkrtdƒ‚|dkrtdƒ‚|j|}|j|}|dkr3td|j|fƒ‚| t|jƒt|jƒ|>@|f¡S)aËThe supernet containing the current network. Args: prefixlen_diff: An integer, the amount the prefix length of the network should be decreased by. For example, given a /24 network and a prefixlen_diff of 3, a supernet with a /21 netmask is returned. Returns: An IPv4 network object. Raises: ValueError: If self.prefixlen - prefixlen_diff < 0. I.e., you have a negative prefix length. OR If prefixlen_diff and new_prefix are both set or new_prefix is a larger number than the current prefix (larger number means a smaller network) rNznew prefix must be shorterr-rÐz;current prefixlen is %d, cannot have a prefixlen_diff of %d)rQrrsr„r{rSr½)rarÑrÒrÓr r r rGÖs&    ÿÿþz_BaseNetwork.supernetcCó|jjo|jjS)ú»Test if the address is reserved for multicast use. Returns: A boolean, True if the address is a multicast address. See RFC 2373 2.7 for details. )rSÚ is_multicastrLr`r r r rÙÿó ÿz_BaseNetwork.is_multicastcCs^z|j|jkrt|›d|›d�ƒ‚|j|jko|j|jkWSty.td|›d|›�ƒ‚w)Nz and z are not of the same versionz*Unable to test subnet containment between )rPr?rSrLrR)Úar¢r r r Ú _is_subnet_of s   ÿ ÿÿÿz_BaseNetwork._is_subnet_ofcCs | ||¡S)z1Return True if this network is a subnet of other.©rÜrŒr r r rÊó z_BaseNetwork.subnet_ofcCs | ||¡S)z3Return True if this network is a supernet of other.rÝrŒr r r Ú supernet_ofrÞz_BaseNetwork.supernet_ofcCr×)úµTest if the address is otherwise IETF reserved. Returns: A boolean, True if the address is within one of the reserved IPv6 Network ranges. )rSÚ is_reservedrLr`r r r rárÚz_BaseNetwork.is_reservedcCr×)ú�Test if the address is reserved for link-local. Returns: A boolean, True if the address is reserved per RFC 4291. )rSÚ is_link_localrLr`r r r rã+sÿz_BaseNetwork.is_link_localcCr×)zÔTest if this address is allocated for private networks. Returns: A boolean, True if the address is reserved per iana-ipv4-special-registry or iana-ipv6-special-registry. )rSÚ is_privaterLr`r r r rä6rÚz_BaseNetwork.is_privatecCs|j S)z×Test if this address is allocated for public networks. Returns: A boolean, True if the address is not reserved per iana-ipv4-special-registry or iana-ipv6-special-registry. )rär`r r r Ú is_globalBriz_BaseNetwork.is_globalcCr×)ú¨Test if the address is unspecified. Returns: A boolean, True if this is the unspecified address as defined in RFC 2373 2.5.2. )rSÚis_unspecifiedrLr`r r r rçMrÚz_BaseNetwork.is_unspecifiedcCr×)ú±Test if the address is a loopback address. Returns: A boolean, True if the address is a loopback address as defined in RFC 2373 2.5.3. )rSÚ is_loopbackrLr`r r r réYrÚz_BaseNetwork.is_loopback)r-N))rrr r r˜r›r¹rºr¼r�rŽržr¿rÀÚ functoolsÚcached_propertyrLrÁrˆrÂrÆrÇrÈrµrsrÎrÏrXrMrGrÙÚ staticmethodrÜrÊrßrárãrärårçrér r r r rWŸsf            K0 5)         rWc@s„eZdZdZdZdZdedZeZiZ dd„Z e dd „ƒZ e d d „ƒZ e d d „ƒZe dd„ƒZdd„Zedd„ƒZedd„ƒZdS)Ú_BaseV4zyBase IPv4 object. The following methods are used by IPv4 objects in both single IP addresses and networks. r rr'r-cCrdrƒrer`r r r r_xsz$_BaseV4._explode_shorthand_ip_stringcCsŽ||jvrBt|tƒr|}d|kr|jksn| |¡nz| |¡}Wnty3| |¡}Ynwt|  |¡ƒ}||f|j|<|j|S©aMake a (netmask, prefix_len) tuple from the given argument. Argument can be: - an integer (the prefix length) - a string representing the prefix length (e.g. "24") - a string representing the prefix netmask (e.g. "255.255.255.0") r) Ú_netmask_cacher=r{rArxr|rrrrt©rrÚargrsr½r r r Ú _make_netmask{s  € ý z_BaseV4._make_netmaskc Csp|stdƒ‚| d¡}t|ƒdkrtd|ƒ‚z t t|j|ƒd¡WSty7}z td||fƒd‚d}~ww)aTurn the given IP string into an integer for comparison. Args: ip_str: A string, the IP ip_str. Returns: The IP ip_str as an integer. Raises: AddressValueError: if ip_str isn't a valid IPv4 Address. úAddress cannot be emptyÚ.rzExpected 4 octets in %rrú%s in %rN)rr)r*r{Ú from_bytesÚmapÚ _parse_octetr)rrr~ZoctetsÚexcr r r r}•s   €ÿz_BaseV4._ip_int_from_stringcCsŽ|stdƒ‚| ¡r| ¡sd}t||ƒ‚t|ƒdkr$d}t||ƒ‚|dkr6|ddkr6d}t||ƒ‚t|dƒ}|d krEtd |ƒ‚|S) a Convert a decimal octet into an integer. Args: octet_str: A string, the number to parse. Returns: The octet as an integer. Raises: ValueError: if the octet isn't strictly a decimal from [0..255]. zEmpty octet not permittedz#Only decimal digits permitted in %réz$At most 3 characters permitted in %rr¤rz%Leading zeros are not permitted in %ré éÿzOctet %d (> 255) not permitted)rryrzr*r{)rrZ octet_strroZ octet_intr r r rø¯s      z_BaseV4._parse_octetcCsd tt| dd¡ƒ¡S)zÒTurns a 32-bit integer into dotted decimal notation. Args: ip_int: An integer, the IP address. Returns: The IP address as a string in dotted decimal notation. rôrr)Újoinr÷r(r!)rrrvr r r ršÓs z_BaseV4._string_from_ip_intcCs&t|ƒ d¡ddd…}d |¡dS)z�Return the reverse DNS pointer name for the IPv4 address. This implements the method described in RFC1035 3.5. rôNrOz .in-addr.arpa)r(r)rý)raZreverse_octetsr r r rgàóz_BaseV4._reverse_pointercCrŠrƒ©rAr`r r r Ú max_prefixlenérÉz_BaseV4.max_prefixlencCrŠrƒrŸr`r r r r@írÉz_BaseV4.versionN)rrr r r‡rPÚ IPV4LENGTHrBrArïr_r‰ròr}røršrgrˆrr@r r r r ríes*    #   ríc@sŒeZdZdZdZdd„Zedd„ƒZedd„ƒZee   ¡d d „ƒƒZ ee   ¡d d „ƒƒZ ed d„ƒZ edd„ƒZedd„ƒZedd„ƒZdS)rz/Represent and manipulate single IPv4 Addresses.)r0Ú __weakref__cCstt|tƒr| |¡||_dSt|tƒr#| |d¡t |d¡|_dSt|ƒ}d|vr2td|›�ƒ‚|  |¡|_dS)a± Args: address: A string or integer representing the IP Additionally, an integer can be passed, so IPv4Address('192.0.2.1') == IPv4Address(3221225985). or, more generally IPv4Address(int(IPv4Address('192.0.2.1'))) == IPv4Address('192.0.2.1') Raises: AddressValueError: If ipaddress isn't a valid IPv4 address. Nrrr&úUnexpected '/' in ) r=r{rpr0r€rqrör(rr}©rarZaddr_strr r r Ú__init__øs    zIPv4Address.__init__cCó t|jƒS©z*The binary representation of this address.)r#r0r`r r r Úpackedó zIPv4Address.packedcCó ||jjvS)z°Test if the address is otherwise IETF reserved. Returns: A boolean, True if the address is within the reserved IPv4 Network range. )Ú _constantsÚ_reserved_networkr`r r r rá ó zIPv4Address.is_reservedcs4t‡fdd„ˆjjDƒƒot‡fdd„ˆjjDƒƒS)áÃ``True`` if the address is defined as not globally reachable by iana-ipv4-special-registry_ (for IPv4) or iana-ipv6-special-registry_ (for IPv6) with the following exceptions: * ``is_private`` is ``False`` for ``100.64.0.0/10`` * For IPv4-mapped IPv6-addresses the ``is_private`` value is determined by the semantics of the underlying IPv4 addresses and the following condition holds (see :attr:`IPv6Address.ipv4_mapped`):: address.is_private == address.ipv4_mapped.is_private ``is_private`` has value opposite to :attr:`is_global`, except for the ``100.64.0.0/10`` IPv4 range where they are both ``False``. c3ó�|]}ˆ|vVqdSrƒr ©Ú.0rCr`r r Ú =ó€z)IPv4Address.is_private..c3ó�|]}ˆ|vVqdSrƒr rr`r r r>r)Úanyr Ú_private_networksÚallÚ_private_networks_exceptionsr`r r`r rä+sþzIPv4Address.is_privatecCs||jjvo |j S)ár``True`` if the address is defined as globally reachable by iana-ipv4-special-registry_ (for IPv4) or iana-ipv6-special-registry_ (for IPv6) with the following exception: For IPv4-mapped IPv6-addresses the ``is_private`` value is determined by the semantics of the underlying IPv4 addresses and the following condition holds (see :attr:`IPv6Address.ipv4_mapped`):: address.is_global == address.ipv4_mapped.is_global ``is_global`` has value opposite to :attr:`is_private`, except for the ``100.64.0.0/10`` IPv4 range where they are both ``False``. )r Ú_public_networkrär`r r r råAszIPv4Address.is_globalcCr )z­Test if the address is reserved for multicast use. Returns: A boolean, True if the address is multicast. See RFC 3171 for details. )r Ú_multicast_networkr`r r r rÙSr zIPv4Address.is_multicastcCs ||jjkS)z¤Test if the address is unspecified. Returns: A boolean, True if this is the unspecified address as defined in RFC 5735 3. )r Ú_unspecified_addressr`r r r rç^r zIPv4Address.is_unspecifiedcCr )z�Test if the address is a loopback address. Returns: A boolean, True if the address is a loopback per RFC 3330. )r Ú_loopback_networkr`r r r réió zIPv4Address.is_loopbackcCr )z’Test if the address is reserved for link-local. Returns: A boolean, True if the address is link-local per RFC 3927. )r Ú_linklocal_networkr`r r r rãsrzIPv4Address.is_link_localN)rrr r r‡rrˆrrárêÚ lru_cacherärårÙrçrérãr r r r ròs,#         rc@sxeZdZdd„Zejdd„ƒZdd„Zdd„Zd d „Z d d „Z e j Z e d d„ƒZe dd„ƒZe dd„ƒZe dd„ƒZdS)rcCóD| |¡\}}t ||¡t||fdd�|_|jj|_|jj|_dS©NF)r)r‚rrrr·r½rQ©rarr+Úmaskr r r r€ó   zIPv4Interface.__init__cCó|jjSrƒ©r·rÁr`r r r rÁˆózIPv4Interface.hostmaskcCód| |j¡|jfSr±©ršr0rQr`r r r r›Œs ÿzIPv4Interface.__str__cCó@t ||¡}|tus |s|Sz|j|jkWStyYdSwr¾)rrŽrZr·rR©rar�Z address_equalr r r rŽ�ó   üzIPv4Interface.__eq__cCsLt ||¡}|tur tSz|j|jkp|j|jko|WSty%YdSwr¾)rr�rZr·rR©rar�Z address_lessr r r r�œó  ÿ ýzIPv4Interface.__lt__cCót|j|jt|jjƒfƒSrƒ©rœr0rQr{r·rSr`r r r rž¨ózIPv4Interface.__hash__cCrrƒ)rr0r`r r r r5­ó zIPv4Interface.ipcCr)rÄr*r`r r r r±ó ÿzIPv4Interface.with_prefixlencCr)rÄ©ršr0r½r`r r r rƶr4zIPv4Interface.with_netmaskcCr)rÄ©ršr0rÁr`r r r rÇ»r4zIPv4Interface.with_hostmaskN)rrr rrêrërÁr›rŽr�ržr]r…rˆr5rÂrÆrÇr r r r r~s"      rc@s2eZdZdZeZddd„Zee  ¡dd„ƒƒZ dS) raeThis class represents and manipulates 32-bit IPv4 network + addresses.. Attributes: [examples for IPv4Network('192.0.2.0/27')] .network_address: IPv4Address('192.0.2.0') .hostmask: IPv4Address('0.0.0.31') .broadcast_address: IPv4Address('192.0.2.32') .netmask: IPv4Address('255.255.255.224') .prefixlen: 27 Tcó¨| |¡\‰}tˆƒ|_| |¡\|_|_t|jƒ}|t|jƒ@|kr5|r+td|ƒ‚t|t|jƒ@ƒ|_|j|jdkrC|j |_ dS|j|jkrR‡fdd„|_ dSdS)aInstantiate a new IPv4 network object. Args: address: A string or integer representing the IP [& network]. '192.0.2.0/24' '192.0.2.0/255.255.255.0' '192.0.2.0/0.0.0.255' are all functionally the same in IPv4. Similarly, '192.0.2.1' '192.0.2.1/255.255.255.255' '192.0.2.1/32' are also functionally equivalent. That is to say, failing to provide a subnetmask will create an object with a mask of /32. If the mask (portion after the / in the argument) is given in dotted quad form, it is treated as a netmask if it starts with a non-zero field (e.g. /255.0.0.0 == /8) and as a hostmask if it starts with a zero field (e.g. 0.255.255.255 == /8), with the single exception of an all-zero mask which is treated as a netmask == /0. If no mask is given, a default of /32 is used. Additionally, an integer can be passed, so IPv4Network('192.0.2.1') == IPv4Network(3221225985) or, more generally IPv4Interface(int(IPv4Interface('192.0.2.1'))) == IPv4Interface('192.0.2.1') Raises: AddressValueError: If ipaddress isn't a valid IPv4 address. NetmaskValueError: If the netmask isn't valid for an IPv4 address. ValueError: If strict is True and a network address is not supplied. ú%s has host bits setr-có tˆƒgSrƒ)rr ©r+r r Úó z&IPv4Network.__init__..N) r‚rrSròr½rQr{rrArºr¹©rarrr$rr r:r rÐs#   ÿ  ÿzIPv4Network.__init__cCs&|jtdƒvo |jtdƒv o|j S)z¹Test if this address is allocated for public networks. Returns: A boolean, True if the address is not reserved per iana-ipv4-special-registry. ú 100.64.0.0/10)rSrrLrär`r r r rås  ÿþzIPv4Network.is_globalN©T) rrr r rrµrrˆrêr rår r r r rÁs 4rc@s¤eZdZedƒZedƒZedƒZedƒZedƒedƒedƒedƒedƒedƒed ƒed ƒed ƒed ƒed ƒedƒedƒedƒgZedƒedƒgZ edƒZ e dƒZ dS)Ú_IPv4Constantsz169.254.0.0/16z 127.0.0.0/8z 224.0.0.0/4r>z 0.0.0.0/8z 10.0.0.0/8z 172.16.0.0/12z 192.0.0.0/24z192.0.0.170/31z 192.0.2.0/24z192.168.0.0/16z 198.18.0.0/15z198.51.100.0/24z203.0.113.0/24z 240.0.0.0/4z255.255.255.255/32z 192.0.0.9/32z 192.0.0.10/32z0.0.0.0N) rrr rrrrrrrr rrr r r r r@s2òþ r@c@sªeZdZdZdZdZdedZdZe dƒZ eZ iZ e dd „ƒZe d d „ƒZe d d „ƒZe dd„ƒZe ddd„ƒZdd„Zdd„Zedd„ƒZedd„ƒZedd„ƒZdS)Ú_BaseV6zyBase IPv6 object. The following methods are used by IPv6 objects in both single IP addresses and networks. r r<r'r-ruZ0123456789ABCDEFabcdefcCsl||jvr1t|tƒr|}d|kr|jksn| |¡n| |¡}t| |¡ƒ}||f|j|<|j|Srî)rïr=r{rArxr|rrtrðr r r ròPs  €  z_BaseV6._make_netmaskc Cs|stdƒ‚t|ƒdkr1|}t|ƒdkr*|dd…›dt|ƒd›d|dd…›�}td |›�ƒ‚|jd }|jd |d �}d }t|ƒ|krOd||f}t|ƒ‚d|dvrˆz t| ¡ƒj}Wntys}z td||fƒd‚d}~ww| d|d?d@¡| d|d@¡t|ƒ|kršd|d |f}t|ƒ‚d} td t|ƒd ƒD]} || s¹| dur·d|}t|ƒ‚| } q¥| du�r| } t|ƒ| d } |dsÛ| d 8} | rÛd}t||ƒ‚|dsí| d 8} | ríd}t||ƒ‚|j| | } | d k�rd}t||jd |fƒ‚n5t|ƒ|jk�rd}t||j|fƒ‚|d�s'd}t||ƒ‚|d�s4d}t||ƒ‚t|ƒ} d} d} z7d}t| ƒD]} |dK}||  || ¡O}�qC|d| K}t| dƒD]} |dK}||  || ¡O}�q`|WSt �y‰}z td||fƒd‚d}~ww)zùTurn an IPv6 ip_str into an integer. Args: ip_str: A string, the IPv6 ip_str. Returns: An int, the IPv6 address Raises: AddressValueError: if ip_str isn't a valid IPv6 Address. róé-édNú(éZz chars elided)iÓÿÿÿz"At most 45 characters expected in r-ú:)Úmaxsplitrúz At least %d parts expected in %rrôrOrõú%xr$éÿÿz!At most %d colons permitted in %rz At most one '::' permitted in %rrz0Leading ':' only permitted as part of '::' in %rz1Trailing ':' only permitted as part of '::' in %rz/Expected at most %d other parts with '::' in %rz,Exactly %d parts expected without '::' in %r) rr*Ú _HEXTET_COUNTr)rrFr0rIr´Ú _parse_hextetr)rrr~ZshortenZ _max_partsÚpartsZ _min_partsroÚipv4_intrùZ skip_indexÚiZparts_hiZparts_loZ parts_skippedrvr r r r}dsž  ,ÿ    €ÿ €    þ      €ÿz_BaseV6._ip_int_from_stringcCs>|j |¡s td|ƒ‚t|ƒdkrd}t||ƒ‚t|dƒS)a&Convert an IPv6 hextet string into an integer. Args: hextet_str: A string, the number to parse. Returns: The hextet as an integer. Raises: ValueError: if the input isn't strictly a hex number from [0..FFFF]. zOnly hex digits permitted in %rrz$At most 4 characters permitted in %rr$)Ú _HEX_DIGITSÚ issupersetrr*r{)rrZ hextet_strror r r rKÕs     z_BaseV6._parse_hextetc Cs¢d}d}d}d}t|ƒD]\}}|dkr'|d7}|dkr|}||kr&|}|}q d}d}q |dkrO||}|t|ƒkr?|dg7}dg|||…<|dkrOdg|}|S)aäCompresses a list of hextets. Compresses a list of strings, replacing the longest continuous sequence of "0" in the list with "" and adding empty strings at the beginning or at the end of the string such that subsequently calling ":".join(hextets) will produce the compressed version of the IPv6 address. Args: hextets: A list of strings, the hextets to compress. Returns: A list of strings. rOrr¤r-Ú)Ú enumerater*) rrÚhextetsZbest_doublecolon_startZbest_doublecolon_lenZdoublecolon_startZdoublecolon_lenÚindexZhextetZbest_doublecolon_endr r r Ú_compress_hextetsïs2€ÿ   z_BaseV6._compress_hextetsNcsZ|dur t|jƒ}||jkrtdƒ‚d|‰‡fdd„tdddƒDƒ}| |¡}d  |¡S) a,Turns a 128-bit integer into hexadecimal notation. Args: ip_int: An integer, the IP address. Returns: A string, the hexadecimal representation of the address. Raises: ValueError: The address is bigger than 128 bits of all ones. NzIPv6 address is too largeú%032xcs&g|]}dtˆ||d…dƒ‘qS)rHrr$)r{©rr£©Zhex_strr r Ú 4s&z/_BaseV6._string_from_ip_int..rrrrF)r{r0rBrr´rUrý)rrrvrSr rXr ršs    z_BaseV6._string_from_ip_intcsŒt|tƒr t|jƒ}nt|tƒrt|jƒ}nt|ƒ}| |¡}d|‰‡fdd„tdddƒDƒ}t|ttfƒrAdd  |¡|j fSd  |¡S) zmExpand a shortened IPv6 address. Returns: A string, the expanded IPv6 address. rVcsg|] }ˆ||d…‘qS)rr rWrXr r rYIsz8_BaseV6._explode_shorthand_ip_string..rrrr²rF) r=rr(rSrr5r}r´rWrýrQ)rar~rvrLr rXr r_9s      z$_BaseV6._explode_shorthand_ip_stringcCs&|jddd… dd¡}d |¡dS)z�Return the reverse DNS pointer name for the IPv6 address. This implements the method described in RFC3596 2.5. NrOrFrQrôú .ip6.arpa)rbÚreplacerý)raÚ reverse_charsr r r rgNrþz_BaseV6._reverse_pointercCs@| d¡\}}}|sd}||fS|rd|vrtd|ƒ‚||fS)zÝHelper function to parse IPv6 string address with scope id. See RFC 4007 for details. Args: ip_str: A string, the IPv6 address. Returns: (addr, scope_id) tuple. ú%NzInvalid IPv6 address: "%r")Ú partitionr)r~r+ÚsepÚscope_idr r r Ú_split_scope_idWs  þ z_BaseV6._split_scope_idcCrŠrƒrÿr`r r r rkrÉz_BaseV6.max_prefixlencCrŠrƒrŸr`r r r r@orÉz_BaseV6.versionrƒ)rrr r r‡rPÚ IPV6LENGTHrBrJÚ frozensetrOrArïr‰ròr}rKrUršr_rgrìrarˆrr@r r r r rA<s6   p  /   rAcseZdZdZdZdd„Z‡fdd„Z‡fdd„Zd d „Z‡fd d „Z d d„Z ‡fdd„Z e dd„ƒZ e dd„ƒZe dd„ƒZe dd„ƒZe dd„ƒZe dd„ƒZe e ¡dd„ƒƒZe dd „ƒZe d!d"„ƒZe d#d$„ƒZe d%d&„ƒZe d'd(„ƒZe d)d*„ƒZ‡ZS)+rz/Represent and manipulate single IPv6 Addresses.)r0Ú _scope_idrcCs�t|tƒr| |¡||_d|_dSt|tƒr)| |d¡t |d¡|_d|_dSt|ƒ}d|vr8t d|›�ƒ‚|  |¡\}|_|  |¡|_dS)aInstantiate a new IPv6 address object. Args: address: A string or integer representing the IP Additionally, an integer can be passed, so IPv6Address('2001:db8::') == IPv6Address(42540766411282592856903984951653826560) or, more generally IPv6Address(int(IPv6Address('2001:db8::'))) == IPv6Address('2001:db8::') Raises: AddressValueError: If address isn't a valid IPv6 address. Nr$rr&r) r=r{rpr0rdr€rqrör(rrar}rr r r rzs    zIPv6Address.__init__cs:|j}|dur tƒ ¡Sd}tƒ ¡}|d|…›|›�S)Né)Ú ipv4_mappedrªr_)rarfÚ prefix_lenÚraw_exploded_strr®r r r_¢s   z(IPv6Address._explode_shorthand_ip_stringcsb|j}|dur tƒ ¡Sd}tƒ ¡d|…}|j}|›|d›�ddd… dd¡}d |¡dS)NreZ008xrOrFrQrôrZ)rfrªrgr_r0r[rý)rarfrgrhrMr\r®r r rgªs  zIPv6Address._reverse_pointercCs>|j}|durtdt|ƒƒ‚|jd?}d| |¡t|ƒfS)aÕReturn convenient text representation of IPv4-mapped IPv6 address See RFC 4291 2.5.5.2, 2.2 p.3 for details. Returns: A string, 'x:x:x:x:x:x:d.d.d.d', where the 'x's are the hexadecimal values of the six high-order 16-bit pieces of the address, and the 'd's are the decimal values of the four low-order 8-bit pieces of the address (standard IPv4 representation) as defined in RFC 4291 2.2 p.3. Nz0Can not apply to non-IPv4-mapped IPv6 address %srz%s:%s)rfrr(r0rš)rarfZhigh_order_bitsr r r Ú_ipv4_mapped_ipv6_to_strµs   z$IPv6Address._ipv4_mapped_ipv6_to_strcs:|j}|dur tƒ ¡}n| ¡}|jr|d|jS|S)Nr])rfrªr›rird)rarfr~r®r r r›Çs  zIPv6Address.__str__cCst|j|jfƒSrƒ)rœr0rdr`r r r ržÏr†zIPv6Address.__hash__cs2tƒ |¡}|tur tS|sdS|jt|ddƒkS)NFrd)rªrŽrZrdÚgetattrr,r®r r rŽÒs zIPv6Address.__eq__cCrŠ)zÈIdentifier of a particular zone of the address's scope. See RFC 4007 for details. Returns: A string identifying the zone of the address if specified, else None. )rdr`r r r r`Ús zIPv6Address.scope_idcCrr)r%r0r`r r r rær zIPv6Address.packedcCó |j}|dur |jS||jjvS)rØN)rfrÙr r©rarfr r r rÙës  zIPv6Address.is_multicastcs.ˆj}|dur |jSt‡fdd„ˆjjDƒƒS)ràNc3rrƒr rWr`r r rrz*IPv6Address.is_reserved..)rfrárr Ú_reserved_networksrlr r`r ráùs zIPv6Address.is_reservedcCrk)râN)rfrãr rrlr r r rãs zIPv6Address.is_link_localcCr ©a`Test if the address is reserved for site-local. Note that the site-local address space has been deprecated by RFC 3879. Use is_private to test if this address is in the space of unique local addresses as defined by RFC 4193. Returns: A boolean, True if the address is reserved per RFC 3513 2.5.6. )r Ú_sitelocal_networkr`r r r Ú is_site_locals zIPv6Address.is_site_localcsHˆj}|dur |jSt‡fdd„ˆjjDƒƒo#t‡fdd„ˆjjDƒƒS)rNc3rrƒr rr`r r r7rz)IPv6Address.is_private..c3rrƒr rr`r r r8r)rfrärr rrrrlr r`r rä"s þzIPv6Address.is_privatecCs|j}|dur |jS|j S)rN)rfrårärlr r r rå;szIPv6Address.is_globalcCó|j}|dur |jS|jdkS)ræNr)rfrçr0rlr r r rçOó  zIPv6Address.is_unspecifiedcCrq)rèNr-)rfrér0rlr r r ré]rrzIPv6Address.is_loopbackcCs |jd?dkr dSt|jd@ƒS)z¶Return the IPv4 mapped address. Returns: If the IPv6 address is a v4 mapped address, return the IPv4 mapped address. Return None otherwise. rrINìÿÿ©r0rr`r r r rfks zIPv6Address.ipv4_mappedcCs4|jd?dkr dSt|jd?d@ƒt|jd@ƒfS)zÛTuple of embedded teredo IPs. Returns: Tuple of the (server, client) IPs or None if the address doesn't appear to be a teredo address (doesn't start with 2001::/32) é`i Né@rsrtr`r r r Úteredoxs  ÿzIPv6Address.teredocCs$|jd?dkr dSt|jd?d@ƒS)zÎReturn the IPv4 6to4 embedded address. Returns: The IPv4 6to4-embedded address if present or None if the address doesn't appear to contain a 6to4 embedded address. épi NéPrsrtr`r r r Ú sixtofour‡s zIPv6Address.sixtofour)rrr r r‡rr_rgrir›ržrŽrˆr`rrÙrárãrprêr rärårçrérfrwrzr¯r r r®r rtsJ (                rcsœeZdZdd„Zejdd„ƒZ‡fdd„Zdd„Zd d „Z d d „Z e j Z e d d„ƒZe dd„ƒZe dd„ƒZe dd„ƒZe dd„ƒZe ‡fdd„ƒZ‡ZS)rcCr!r")r‚rrrr·r½rQr#r r r r—r%zIPv6Interface.__init__cCr&rƒr'r`r r r rÁŸr(zIPv6Interface.hostmaskcsdtƒ ¡|jfSr±)rªr›rQr`r®r r r›£s ÿzIPv6Interface.__str__cCr+r¾)rrŽrZr·rRr,r r r rާr-zIPv6Interface.__eq__cCsLt ||¡}|tur |Sz|j|jkp|j|jko|WSty%YdSwr¾)rr�rZr·rRr.r r r r�³r/zIPv6Interface.__lt__cCr0rƒr1r`r r r rž¿r2zIPv6Interface.__hash__cCrrƒ)rr0r`r r r r5Är3zIPv6Interface.ipcCr)rÄr*r`r r r rÂÈr4zIPv6Interface.with_prefixlencCr)rÄr5r`r r r rÆÍr4zIPv6Interface.with_netmaskcCr)rÄr6r`r r r rÇÒr4zIPv6Interface.with_hostmaskcCs|jdko|jjS)Nr)r0r·rçr`r r r rç×szIPv6Interface.is_unspecifiedcstƒjo|jjSrƒ)rªrér·r`r®r r réÛrÃzIPv6Interface.is_loopback)rrr rrêrërÁr›rŽr�ržr]r…rˆr5rÂrÆrÇrçrér¯r r r®r r•s*         rc@s2eZdZdZeZd dd„Zdd„Zedd„ƒZ d S) ravThis class represents and manipulates 128-bit IPv6 networks. Attributes: [examples for IPv6('2001:db8::1000/124')] .network_address: IPv6Address('2001:db8::1000') .hostmask: IPv6Address('::f') .broadcast_address: IPv6Address('2001:db8::100f') .netmask: IPv6Address('ffff:ffff:ffff:ffff:ffff:ffff:ffff:fff0') .prefixlen: 124 Tcr7)aæInstantiate a new IPv6 Network object. Args: address: A string or integer representing the IPv6 network or the IP and prefix/netmask. '2001:db8::/128' '2001:db8:0000:0000:0000:0000:0000:0000/128' '2001:db8::' are all functionally the same in IPv6. That is to say, failing to provide a subnetmask will create an object with a mask of /128. Additionally, an integer can be passed, so IPv6Network('2001:db8::') == IPv6Network(42540766411282592856903984951653826560) or, more generally IPv6Network(int(IPv6Network('2001:db8::'))) == IPv6Network('2001:db8::') strict: A boolean. If true, ensure that we have been passed A true network address, eg, 2001:db8::1000/124 and not an IP address on a network, eg, 2001:db8::1/124. Raises: AddressValueError: If address isn't a valid IPv6 address. NetmaskValueError: If the netmask isn't valid for an IPv6 address. ValueError: If strict was True and a network address was not supplied. r8r-cr9rƒ)rr r:r r r; r<z&IPv6Network.__init__..N) r‚rrSròr½rQr{rrArºr¹r=r r:r rðs   ÿ  ÿzIPv6Network.__init__ccs>�t|jƒ}t|jƒ}t|d|dƒD]}| |¡VqdS)z¢Generate Iterator over usable hosts in a network. This is like __iter__ except it doesn't return the Subnet-Router anycast address. r-Nr³r¶r r r r¹ s €  ÿzIPv6Network.hostscCr×rn)rSrprLr`r r r rp, s ÿzIPv6Network.is_site_localNr?) rrr r rrµrr¹rˆrpr r r r ràs 0 rc@sðeZdZedƒZedƒZedƒedƒedƒedƒedƒedƒed ƒed ƒed ƒed ƒedƒg Zed ƒedƒedƒedƒedƒedƒgZedƒedƒedƒedƒedƒedƒedƒedƒedƒedƒedƒedƒedƒed ƒed!ƒgZed"ƒZ d#S)$Ú_IPv6Constantsz fe80::/10zff00::/8z::1/128z::/128z ::ffff:0:0/96z64:ff9b:1::/48z100::/64z 2001::/23z 2001:db8::/32z 2002::/16z 3fff::/20zfc00::/7z 2001:1::1/128z 2001:1::2/128z 2001:3::/32z2001:4:112::/48z 2001:20::/28z 2001:30::/28z::/8z100::/8z200::/7z400::/6z800::/5z1000::/4z4000::/3z6000::/3z8000::/3zA000::/3zC000::/3zE000::/4zF000::/5zF800::/6zFE00::/9z fec0::/10N) rrr rrrrrrmror r r r r{< s@óú      ø r{r?)$r Ú __version__rêrrbrrrrrrr#r%r,r6r:rDrNrVr\r]r¦Útotal_orderingr>rWrírrrr@r rArrrr{r r r r Ús^ "7163kH CR&:#K\ /